1

Simple as it sounds, I have tried UNetbootin which will produce something that won't boot, as is balenaEtcher. I have tried WoeUSB that is way to complex for my limited knowledge of Linux, and won't work either.

I want a point-click-done GUI solution, like rufus for windows. Why should it be so hard to create a bootable usb?

1 Answer 1

1

I've been there, friend; I can feel it. You can follow either of the methods mentioned below according to your convenience (I recommend No. 2):

  1. You can use the dd command to write the image to the disk.
  • sudo dd bs=4M if=/path-to-image/image-name.iso of=/dev/sdx status=progress && sync

  • points to note:

  • In place of sdx put your drive label(can be identified with command lsblk ).

  • In 'if= ' put the file path for the iso image[for example: /home/harshu/downloads/windows.iso].

  • In 'bs= ' you can put any amount but I recommend to keep it 4M.

  • NOTE: This method might not always work for "windows" image files.

  1. You can use ventoy and it is very easy to setup.
  • Download latest release of ventoy for linux (you can find the latest release here).
  • Extract the zip content of the file you just downloaded.
  • Open terminal in the ventoy folder and enter the following command: sudo ./VentoyWeb.sh
  • Then go to 'http://127.0.0.1:24680' (as it is already mentioned in terminal after running VentoyWeb.sh, Warning do not click ctrl+C yet).
  • select the desired drive and flash it.
  • Then click ctrl+C in terminal.
  • Now you can see that a drive named "Ventoy" has been mounted.
  • Now copy the iso image file and paste it in Ventoy drive.
  • after copying is finished boot from ventoy usb and select the desired iso file and you're good to go.
  • You can also put multiple iso files if you have enough storage. Then whenever you boot from ventoy you can choose from multiple different .iso's .
  • NOTE: Windows 7 iso might not work as per my experience any other iso mentioned over here will definitely work.
  • If you couldn't follow my guidance in this method, here is the website's guide.

I've gone through the exact same scenario as you, I was in zorin OS lite and I have tried the methods you have mentioned in the question and none of them worked for me too. Finally I made my brother flash it for me via rufus since he uses windows. Then flashing failed many times for that particular drive and Ultimately I landed on Ventoy and it worked like a charm.

I hope this answer might help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.