1

To connect with the device boards like- Switch, Ap, etc. previously I used minicom 2.7 in my previous laptop having ubuntu16.04. there I can perform read and write both operations. But recently I buy a new laptop on top of Ubuntu18.04, install minicom 2.7.1 but in my new setup, I have only read access not able to write anything on that board. So I am looking forward to the alternate for minicom. I have tried almost everything but it's not working for me write operations must be there on board. So if anyone has any recommendations for this or have an alternate solution for the same.

NOTE: I have tried this in both systems (16.04 and 18.04). with same USB-uart combination for 16.04 working perfectly fine but for 18.04, it is not(only have read access).

  • Grab the source for the old working version, build it, and install it. – ivanivan Jul 4 '19 at 13:55
  • 1
    Thanks, @Mawg, GTKterm is worked well. just I need to figure-out the baud rate for my other devices. FYI: Already gone through this link but due to too many options are available I tried few of them from the top those are not working for me. but after exploring more One of the available option worked for me(GTKterm). – dragon Jul 5 '19 at 5:17
  • Feel free to post that as an answer, with some description to help others who read the question in future. Since you are new, you might not be aware of our Unix & Linux sister site. – Mawg says reinstate Monica Jul 5 '19 at 6:26
1

Here is the answer to my above query.

Alternate solution for minicom is Gtkterm, this is easily available and quite handy to use.
Steps to configure Gtkterm -
(i) From Ubuntu software center install gtkterm serial port access.

(ii) In terminal "sudo gtkterm" will appear the new terminal interface.

(iii) From there configure -> port-> port(dev/ttyUSB0) - > baudrate(in most of the case)-> 115200

if still no logs appear you need to figure out the baudrate for your console deivce.

for more info - https://elinux.org/Communicate_with_hardware_using_USB_cable_for_Ubuntu

Limitation - here is the list of limitation I figure out till now and I am working on it. as soon as will resolve this, will post the solutions here.

1 - There is no infinite scrolling, due to unavailability of preference.

Ans - Configure ->main window -> scroll back line. 
Note - Limitation 3000 lines.

2 - unable to find the matched string as we do in minicom.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.