1

I am using a synology NAS that has a L2TP/Ipsec VPN server running.
On debian and android the connection works great. But on Windows 10 it is a 50/50 game if it will work or not.

I tried a lot of things to get it work but sometimes it is nearly impossible.
And because windows is not reliable in that point, I thought I could try a alternative to the build in windows VPN client.
A program, that can establish the L2TP/Ipsec vpn connection.

But the programs i find (freelan, softether, ...) have all theire own server runtimes as well.

So what programs for windows are out there, that can connect to a existing L2TP/Ipsec vpn? Any suggestions?

quick overview:
price: free
os: windows 10
purpose: connect to an existing L2TP/Ipsec VPN Server that is hosted on a synology NAS

thanks and greetings

1

You can use ShrewSoft VPN client under Standard Edition, which is free, I have used it in the past without any issues. It supports L2TP/IPSec.

Please make sure that you select the Standard Edition, during the set up instead of the Professional, as the professional requires a license after 14 days.

  • thanks for the recommendation. But the newest release is from 2013 and so I am not fully convinced. – christopher2007 Sep 12 '18 at 19:00
  • 1
    We've used it extensively with a lot of users with not issues. A try might convince you. – Sonamor Sep 12 '18 at 19:02
  • ok, I try it. Thanks a lot. But after installing the program, the gui confuses me. I found the spot to put the preshared key, but where does the username and password go? I don't find input fields. – christopher2007 Sep 12 '18 at 19:21
  • 1
    When you configure your connection then you double click on it and you will be prompted to type in your username and password – Sonamor Sep 12 '18 at 20:19
  • thanks for the help so far. But I do not get a connection at all. I posted all my configurations below. Maybe you could help me? that would be so nice. – christopher2007 Sep 13 '18 at 8:26
0

I tried ShredSoft VPN like sonamor recommendet.
So far it seems like a basic program with a lot of functions and no modern bad designed UI. So nothing confusing.

But I have problems connecting with it to my VPN. And the hole point of using a third party program instead of the Windows 10 build in VPN module is, that it should work.

When I connect, I always get a log like this:

config loaded for site 'testVPN'
attached to key daemon ...
peer configured
iskamp proposal configured
esp proposal configured
client configured
local id configured
remote id configured
pre-shared key configured
bringing up tunnel ...
negotiation timout occurred
tunnel disabled
detached from key daemon

And the line negotiation timout occurred is red.

So here are all my configs:

In the router, that is in the network of the VPN Server, the Ports 1701, 500 and 4500 are opened to the VPN Server. All UDP.

The VPN Server is a Synology NAS that has the following configuration:
Synology NAS VPN Server configuration

And my ShrewSoft software has the following configurations:
ShrewSoft configuration

And with this settings I get the log from above.

Like I already mentiond:
With other Windows 10 computers I can connect, also with my Android 7 phone.

As an example, here are the configs of the Android 7 phone:
Android 7 VPN configuration

So what am I missing in this recommendet program?
If it will not run, I maybe need an other program. But so far ShrewSoft makes a good impression, but only an impression so far ...

thanks for any help and greetings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.