1

My project is limited to python 2.4 due to, unfortunately, an essential third party library. I have a number of tests written using the unittest module. I would like to track test coverage. Is there a code coverage tool for python 2.4? I believe coverage.py does not work with python 2.4.

  • 1
    Python 2.4.6 was released in 2008. You are in deep. – tripleee Apr 12 '18 at 13:01
  • Oh I know. It's bad. – pls Apr 12 '18 at 15:58
  • At least you don't have a professor teaching that C doesn't have a Boolean data type. It's been in the standard since C99! There will always be legacy code, and legacy knowledge. – CAD97 Apr 13 '18 at 5:14
0

Coverage.py 3.7.1 runs on Python 2.4: https://pypi.org/project/coverage/3.7.1/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.