3

Existing addons (such as nobuffer and flashblock) seem to have stopped working; and youtube hasn't given users an option to prevent videos from buffering and playing automatically since they introduced this "feature". I've tried changing media.autoplay.enabled in about:config to false, but it had no effect (aside from breaking Pandora).

Notes:
I want to stop both flash and html5 videos from autobuffering/playing.
Nobuffer used to accomplish that.
Flashblock used to block both flash and html5 video; but now YT videos seem to be encased in some sort of shell which prevents even flashblock from stopping autoplay/buffer.
I don't care about embedded videos or facebook. I need this to work on Youtube.com.
I need a solution that won't break Pandora (or that can be easily enabled/disabled).

  • it may be a little bit of a overshoot, but NoScript can do this... – DJCrashdummy Apr 22 '17 at 9:10
  • I just tried it (I already have it installed but generally keep it disabled). It didn't work. I removed youtube from the whitelist. Still didn't work. Am I missing something? – Sebastian Hahn Apr 25 '17 at 7:22
  • maybe you have to check your settings... some further reading about this topic: noscript.net/features#contentblocking – DJCrashdummy Apr 25 '17 at 8:08
0

There is an extension called "Disable HTML5 autoplay" which sounds like it does the thing you want it to do. As for Flash content, it appears that this is still covered by your existing addons (and due browsers dropping flash anyways, this is going to become irrelevant in the medium-term future).

  • This only prevents auto play. OP is asking for prevention of buffer as well. – Ameer Jul 16 '17 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.