12

I'm looking for a Linux file manager:

  1. Graphical.
  2. Desktop environment neutral, plain GTK or Qt libs are OK, I just don't want to install million services from GNOME or KDE just to use a single app.
  3. Has keyboard shortcuts that do not include the use of arrow keys as I don't want to move my fingers from touch typing position. For example Midnight Commander has Ctrl+n, Ctrl+p, Alt+n and Alt+p for moving in the file lists which is great.
  4. Has thumbnails so that I can preview images.
  5. Preferrably twin panel.

Double Commander has all of this except the keyboard navigation. Midnight Commander has everyting except the thumbnails and is not graphical. All the ones I've tried fail in some way (GNOME Commander, emelFM, SpaceFM, 4Pane, gentoo, Tux Commander).

  • Have you looked at mc? It's not exactly graphical, but it is the closet you will get to keyboard only. – Seth May 8 '14 at 1:49
4

XFE is your next file manager. image thumbnail support

  • It is graphical, in the same way DC is at least.
  • It aims at being light, and only requires the FOX library.
  • It has configurable key bindings, so you can express your hate of arrow-keys
  • It has thumbnails so you can preview image
  • Like any cool file manager, it is twin panel (it descends from X Win Commander, which makes it a distant cousin of Midnight Commander).
  • I installed it, it looks really great, but unfortunately, you can't move with keyboard, you still need to either use mouse to click on the directory or to move fingers and use arrow keys :( – Vitomir Kovanovic May 4 '14 at 8:25
  • Have you tried editing key bindings? – VicAche May 4 '14 at 10:27
  • Yes, there is no way to customize that :(, it is like in the DC, you can customize all bunch of the shortcuts (what triggers what action) but not for moving around :(. And that is the most important one, I can get used to pressing any key combo for a rare action of unzipping a file or something like that :( – Vitomir Kovanovic May 4 '14 at 20:48
  • Have you tried system settings? In gnome there is an emacs-mode which would do the tric, if it hasn't been destroyed by the gnome 3 folks... – VicAche May 4 '14 at 21:03
  • I've finally made the Emacs settings to work, but still navigation in DC or XFE is not working :( – Vitomir Kovanovic May 10 '14 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.