0

I downloaded a website on my computer and transferred it to my Nexus 7 tablet (4.4.4 Omni ROM), but am unable to find an app that can browse it properly. The website I'd like to browse is the Android developer documentation (weighs in at about 1 GB), which I obtained through the SDK manager.

I put the website root folder (called docs) into my Android eBooks directory. I used the default file manager to browse to docs/index.html and clicked it to choose an app to use.

I'm looking for an app that will load the website with images and other (offline) content present, the same way it appears in a browser on my computer.

I tried using Dolphin

  • index.html:

    index.html in Dolphin

  • After clicking any link:

    Dolphin: Webpage not available

I tried using the default HTMLViewer

  • index.html:

    index.html in HTMLViewer

  • After clicking any link:

    HTMLViewer: Webpage not available

I tried using Offline Browser

  • which seemed promising, but did not even load index.html:

    Offline Browser: Webpage not available

The website already uses relative links, as this screenshot in Chrome shows (or as can be seen directly in the HTML)

enter image description here

  • 1
    Thank you for your edits @unor :) – Aralox Jul 31 '16 at 2:52
1

You can try my browser app. It supports offline HTML browsing and also bundles a read-only file explorer. It has four scrolling buttons on its toolbar for navigating the pages. FYI, Android API docs require a tablet-size screen.

Subhash Browser & Feed Reader for Android Subhash Browser offline HTML browsing

As Steve Barnes says, the docs will be displayed properly only if you had copied the docs folder from the copy downloaded by the Android SDK toolkit. If you have scrapped it from the website using some other tool, it may not work very well.

  • Thank you! It actually worked perfectly! It loads the file quickly, and everything looks great. I think the key point was that I manually typed in the file url: file:///storage/emulated/0/ebooks/docs/index.html. I found that the default browser and Chrome also managed to open the website properly with the direct file url, but very slowly with weird problems with internal links. Dolphin couldn't open the file path at all. Your browser is actually the best solution, and I'm really happy there are no ads and that the top bar can be minimized. Thanks again. – Aralox Aug 6 '16 at 5:23
0

Your problem is not with your browser(s) but rather with the way that you downloaded the web site - you need to either:

  • Use a proper web scraper which will do the job automatically or
  • Fix, by editing or using a script to edit, all of the links in your downloaded files so that instead of pointing to content://some_web_site it points to file:///etc

You may find that you are a lot better off getting a ready made ebook such as Android Studio Development Essentials

  • Thanks for the reply Steve. Could you please elaborate on how I'd go about fixing the links in the html files? They already all use relative links (I edited the question with a screenshot) - what else should I change? Also, would this question be more appropriate on another SE site, maybe Android Enthusiasts? – Aralox Jul 31 '16 at 2:54
  • @Aralox - Do the relative links match the structure under your docs folder so in the screenshot you are looking at K:/andrios-sdk-windows/docs/develop/index.html and the highlighted link is to ../training/index.html so does K:/andrios-sdk-windows/docs/training/index.html exist? Keep in mind that android is case sensitive! Also there is a fair bit of JS in there have you tried chrome on your device? – Steve Barnes Jul 31 '16 at 6:38
  • The relative links seem to match the docs folder fine, plus it works on a computer. I tried using Chrome on the tablet, but had the same results. I think I have a lead, though. The root index.html has this URI in Chrome: content://com.android.externalstorage.documents/document/primary%3AeBooks%2Fdocs%2Findex.html, but when I click on the 'training' link, it takes me here content://com.android.externalstorage.documents/document/training/index.html. I suspect that primary%3AeBooks%2Fdocs%2Findex.html is being treated as one whole directory. I think the %3s and %2s should be slashes – Aralox Aug 5 '16 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.