19

The question:

I'm looking for a tool to remotely access/administrate Android devices within the same network (so no cloud based stuff, please). I'd like to

  • see the display/screen content
  • be able to launch apps
  • be able to access settings
  • be able to interact with "activities" (i.e. control apps, change settings)
  • access to calls/SMS is not required
  • the app should not require excessive permissions
  • FOSS solutions strongly preferred, other free solutions welcome. Paid solutions are only acceptable if there's a "trial" available (I don't want to buy a pig in a poke).
  • the client preferably runs in a web browser. If it requires a native application, that must support Linux.

Note that Airdroid already disqualified itself completely (see below for details).


Some background explanation

Obviously, a kind of VNC server running on the Android device would be a good choice – but all existing solutions are outaged (last updated 2013 or earlier). I'm currently using PAW Server, but that doesn't cover all requirements (e.g. I cannot see the device's screen or interact with apps). Airdroid1 and Webkey are out of the equation as they work via the cloud (unfortunately, as Airdroid would fit quite nicely apart from requiring quite a lot of permissions – and Webkey would meet the FOSS part even) – and all other candidates known to me are again outdated.

Solutions requiring a rooted device are welcome (all my devices are rooted), though solutions not requiring root might be preferable.

Related questions I've already checked:


1 PS: Reading the Airdroid FAQ I just found it should be possible to use "LAN connection" (i.e. not via the Airdroid server) without an account at the Airdroid site. It also describes a Lite Mode, described as "connect your Android devices directly, without passing through the AirDroid web servers" but pointing out that "Some AirDroid web features are missing in Lite Mode." So if someone is using this and can point out how to ensure that no data will leave the local network, Airdroid might be a valid option (obviously depending on what features go missing (which the FAQ lacks to say), and if the remaining features still match my requirements ;). Airdroid's permission requirements are well explained so I could live with that (Xprivacy can deal with them).

I've just given Airdroid a try on a "clean device". While I remember its usefulness from the early versions (whee it did not have any cloud service), it's an absolute no-go now:

  • right at the first start, before you even get to see the app's interface, it already wants to connect to Facebook (EEEK!!!)
  • checking the config (first thing I usually do), I see it has some "push service" enabled – and also "sending crash reports" (without asking me, to me this is a privacy violation)
  • it offers neither https (at least not in local mode) nor a password protection. Having to confirm a connection on-device is one thing – but it's impracticable when the device is not near (but e.g. at the other end of the house)
  • invoking the web interface from my browser I see I can do almost nothing: a blank screen with a status bar, a search box (Google Play and Quixey – WTF?), an "about button", creating a message or making a call, turn it off (switching screen size (to "mobile view" and back) seems to have brought the missing elements at least, and enabling cookies (which Airdroid didn't ask for) enabled interaction).
  • the web interface has Google Analytics embedded (EEEK!)
  • even in local mode, the web interface loads stuff from the mothership. I found no setting to disable that.
  • the final kick: after all those concerns, it wants root permissions to show me the device screen. No way: you've already lost my trust, Airdroid.

So as nice as it might be with cloud, it's completely out of the equation for the privacy-concerned.


Solutions checked

  • Airdroid: no-go, see above
  • Vysor: Requires Chrome (which again is known to "phone home" a lot) and ADB (one of the devices in question is at the other end of the house, and I couldn't get "ADB via WiFi" running on it, so it wouldn't work)
  • stf: A lot of dependencies, incl. again ADB (see previous point) and more – sounds a bit heavy
8
  • have you tried: droid VNC server (open source), android-vnc-server, VNC server by onecent?
    – eadmaster
    Jul 5, 2016 at 17:22
  • Thanks, @eadmaster – but have you checked my remark on those above ("all existing [VNC] solutions are outaged"), and compared that with your suggestions? 2012 / 2012 / unavailabe. Unfortunately not very convincing. If you could name one that's still actively maintained, things would be different :)
    – Izzy
    Jul 5, 2016 at 18:41
  • Strange. Last playstore update was 2012 (the master brach matches that – that there were 5 commits in May (2 of them just the merges, and 1 just the Makefile, which leaves 2 real ones), being the only ones dating post 2012, cannot really be seen as "still maintained" but rather "a sporadic burst", sorry), and a rating of 3.4 is not very convincing. Last (and only) release according to the repo linked was even back in 2011. It doesn't help me much if they do some commits every few years but never publish a build.
    – Izzy
    Jul 5, 2016 at 18:51
  • I understand, i've tried it couple of times on Android 4 and it was working, but it required root privileges.
    – eadmaster
    Jul 5, 2016 at 19:05

6 Answers 6

1

Came across this thing: https://github.com/oNaiPs/droidVncServer this is not the same as airdroid. Discontinued, so possibly works for KK. The description is scarce, must be testrun. No word what OS this is for Win or Linux, but looking at the scary compile commands, its probably for Linux. Most people would walk by it, but we know you're desperate by now. Good luck

6
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review Aug 13 at 4:24
  • @RohitGupta why do you think this does not answer the question? VNC access would meet most of the requirements. Unfortunately, the one linked is no longer maintained (and doesn't provide an APK). The other 2 I know of don't support KK, but might be useful to those not having that restriction. // Kontovski: No, I'm not "desperate". I meanwhile mostly abandoned the idea even, just following it here out of interest. The original use-case no longer exists, my question was asked 6 years ago ;) So thanks for the suggestion, should have thought about this back then…
    – Izzy
    Aug 13 at 21:56
  • "No word what OS this is for" – going by the name it's most likely for Android (carrying the "droid" part). The other alternatives to it I mentioned can be found here in my corresponding app listing.
    – Izzy
    Aug 13 at 22:01
  • Actually, I apologize, because I last read this question in full a while ago, and evidently have forgotten by now that this exact title have already been mentioned before and even discussed buy you. I believed I am bringing in a totally unknown title up for a discussion.
    – Kontovski
    Aug 14 at 7:30
  • @Izzy - Because the question has android in the tag and the answer says that he is not sure what OS it's for - possibly Windows or Linux. But not Android. And I did not downvote it. Aug 19 at 4:34
0

I was looking for something similar for different reasons.

What about the desktop version of Vysor?

Unlike the old version, this doesn't need Chrome, it's stand alone.

It allows you to connect to your android device via USB or via the device's local ip.

I only tested it via USB, but it worked fine when neither Windows laptop nor phone were connected to the internet. I can't vouch for whether it ever phones home, but even if it does you could potentially use a firewall rule to prevent it from accessing the internet.

You can input via the cursor and mouse, which will let you do anything that you would be able to do with the phone in your hand.

Link: https://plus.google.com/110558071969009568835/posts/Ub7QKu2Pddu

It has Windows and Mac versions. Sounds like you might still need chrome to run it in Linux... or whatever electron-chrome is.

8
  • Co-incidence: I've just checked their website a couple of minutes ago, and it read like a subscription service (from US$ 2/month to 10/year or 40/lifetime). The site's "install" button still redirects to the Chrome extension. Didn't see any other "desktop version" (maybe you could provide a link to the Linux version?) – and I rather prefer to be sure it doesn't "phone home". Sure, I could setup firewall rules to only permit it to the local network – but I'd rather avoid too much fiddling ;)
    – Izzy
    Mar 21, 2017 at 17:04
  • See edit. It has a linux version but running it Windows or OSX looks simpler
    – Ne Mo
    Mar 21, 2017 at 17:10
  • Oh, and it has a free version. Don't know if that's any good to you
    – Ne Mo
    Mar 21, 2017 at 17:13
  • "Looking simpler" on Mac/Win doesn't help me, as I'm not using those systems. And being chrome-based (whatever flavor) makes it a no-go for me, sorry. electron-chrome is chrome API based on NodeJS. Oh, interesting side-mark: It's developed by Koush (Koushik Doutta), and he uses that to distribute Vysor.
    – Izzy
    Mar 21, 2017 at 17:14
  • Just trying to help buddy! Wine or virtualbox might be worth exploring there
    – Ne Mo
    Mar 21, 2017 at 17:17
0

I don't have actual experience with this, But it sounds like it would work for you. Check out scrcpy https://github.com/Genymobile/scrcpy It uses ADB, however you can use any ADB over ethernet app and OTG cable to bypass the wifi limitation.

3
  • Thanks – but as I pointed out in my question: and I couldn't get "ADB via WiFi" running on it, so it wouldn't work – and cable-bound solutions won't work either as the device is "not in cable range".
    – Izzy
    Jun 17, 2019 at 6:54
  • Sorry, I misunderstood. I thought you couldn't get ADB over Wifi running on Vysor, not on the device.
    – user218076
    Jun 17, 2019 at 12:20
  • 1
    No, on that specific device (a good old and stable Motorola Milestone 2 running Android 4.4 thanks to CM; still good as a night stand and morning alarm – could do more if… well, see the question). Thanks nevertheless: your answer might be helpful to others!
    – Izzy
    Jun 17, 2019 at 19:07
0

Windows PhoneLink (former MyPhone) can do this

https://support.microsoft.com/en-us/topic/introducing-microsoft-phone-link-and-link-to-windows-2e4bb4c0-f99a-4464-92a8-5264c7c39734

Of course it covers not all the things from your list of requirements, but basic ones it does.

It can:

  • show phone screen
  • show messages
  • show call log
  • send SMS
  • call from phone
  • display phone notifications, remove them
  • other stuff I'm not aware off

Yesterday I was testing some stuff and occasionally had an opportunity to test this app, it works fine for basic things.

enter image description here

The main perk: it is free and exist on every Windows installation.

3
  • Hm, nice to see – but does it meet "must support Linux"? The only windows I have here are for letting light in – and I open them only to get fresh air…
    – Izzy
    Jul 20 at 16:28
  • well, I was aiming at tags, and there is no linux tag is assigned to this question, so I treated it more broad way
    – Suncatcher
    Jul 21 at 7:15
  • Well, the text had it ;) Thanks nevertheless – so I take it's a "no". Might still be useful for others, so let's keep it :)
    – Izzy
    Jul 21 at 17:23
0

Well, this suggestion is not well researched. This is because I only answer with what I know now, don't have the time for a research that I don't need, sorry. With that said, I am researching a better remote access tool for my windows (when I say that I do not consider anything above 7 "a windows", NSA tool maybe yes. So, I saw this tool and remembered your question. The tool is Rustdesk, and below is the url for the manual page talking about controlling android. What I know about it already: -open source -self host option -end to end encryption -access from linux -Android 6 and up is required for screen sharing -Android 10 or up is required to share the internal audio of the mobile phone system

Permissions: -Screen Capture Whether to enable screen capture sharing permission, the monitoring service will be enabled at the same time as startup -Input Control* Whether to allow the controller to control the input of the mobile phone, such as virtual touch screen operation with the mouse -File transfer* Whether to enable file transfer permission, after startup, you can remotely control the file system of this phone -Audio capture Whether to share the system music inside the phone (not microphone input)

https://rustdesk.com/docs/en/manual/control-mobile/ perhaps there is more if you read more into it, - I am looking to try it to control my PCs, but now starting to wonder about using it on phones too!

I am on android 7 or 8, currently running on LGV20 H918 platform, some rooted, some not, some 7, some 8, some ruined by me trying to re-solder/replace the USB-c port.

I am currently using "MyPhoneExplorer" and it does a lot for me and I like it, plus, it has a forum in Deutsche (unexplained interest to Germany even though my language progress is very very little). The MPE seem to only build windows versions. But, if you manage to run it from a win emulator, this might work for you? I would recommend you to try it even if from an emulator, because you need to see how much it does for maintenace/backup tasks. https://www.fjsoft.at

PS: is Izzy a short for a German name? Pass auf

3
  • Rustdesk would probably be a very good choice, as it's even available at F-Droid. Unfortunately, the device to be monitored runs an old Android version – too old for Rustdesk (it's only accessible in the local network, and yes I'm aware of the risk but they hardly apply). // I know MyPhoneExplorer, but: No Windows except for light and fresh air. I don't trust MS further than I can throw the Eiffel tower. // As to the name: nope, not a German one. Watch out for Isak, Isaac, Yitzchak & Co ;)
    – Izzy
    Jul 28 at 23:50
  • Got it. I used to always use MPE on my older androids starting from Ginger Bread. Could it be possible that someone ported the MPE to linux? It is really good. Maybe search for this or maybe someone already asked that on their forum. I will be looking for that later as well, I think, gotta support androids of my relatives. But not yet. Want to move to Linux, but this is exactly the issue: lack of software choice (as compared to win). What to do. 7 is gonna soon be obsolete.
    – Kontovski
    Jul 29 at 1:11
  • Thanks! The urgency of this taks has dropped a lot meanwhile (I'm still interested to know, but probably won't find much time playing with it). Besides, I'm using Linux for over 20 years now, I don't miss things from Windows (especially not their tracking stuff, the permanent "anti-virus" issues, or losing half of the resources for stuff I didn't want in the first place). A few things would be nice-to-have, yes, like MyPhoneExplorer. But then, I try avoiding closed-source solutions whenever possible. Windows shows us where that might end up otherwise…
    – Izzy
    Jul 29 at 6:46
0

Just saw this: Meshcentral
https://meshcentral.com/info/index.html
https://play.google.com/store/apps/details?id=com.meshcentral.agent2

I can see an option for lan-based self run web server, free, open, and Linux is listed as a server option, while on their main site in the download section, there is an android app for direct download and play store (link above).

Looks promising but I can't find minimal supported android version, so who knows if it will run KitKat?

1
  • Nice find! Minimal Android version supported is MM (6.0) as you can see when looking at the playstore listing via Appbrain (or on Play, tap the arrow next to "about the app"). So my KK device won't run it. Further, the app comes with Firebase inside (tracking), depends on Google Services – and the server part needs NodeJS. And most important: wrong direction it seems. From the manual: "remote control and manage computers that runs either Windows* or Linux* OS." So Android is just a client to control the PC.
    – Izzy
    Jul 29 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.