0

My WiFi connection drops and reconnects frequently. On each reconnect, it pops up a message stating "connected to WiFi network {SSID}", which is quite annoying.

Is there an Xposed module that will disable that notification?

  • NotifyClean? – Firelord May 2 '16 at 15:32
  • Tried that, it doesn't seem to pick up this notification. This notification occurs at the bottom of the screen, not in the top bar. It's not one of the ones listed in notifyclean under phone, system ui or android system :/ – Ne Mo May 2 '16 at 15:41
  • 1
    Are you sure it is a notification and not a toast? If a toast, have you tried EnhancedToast? Perhaps a screenshot would do good here. – Firelord May 2 '16 at 15:58
  • 1
    For some background on what @Firelord is asking, please see Popups, dialogs, notifications, toasts: what's the difference? on our Android sister site. – Izzy May 5 '16 at 22:05
  • My mistake, it was a toast. That module suggested killed it, thanks. – Ne Mo May 6 '16 at 8:56
1

That message is displayed as a Toast. The solution is the Xposed module EnhancedToast which can hide any toast it had recorded so far since it was installed. You have to install it → enable its module under Xposed Installer app followed by reboot → launch it → select your app2 → select the toast to hide it. Selecting an entry would turn its background color to red.

Note: an Xposed module requires a compatible1 Xposed framework installed.

Example:

(Click an image to enlarge it)

IMG: IMG:


1 Xposed Framework: Android 4.x, 5.x and 6.x
2 My take is that either it is Android System or Settings or SystemUI responsible for creating that toast.

  • 'Settings' is responsible for the toast. If you disable toasts from that app, you might not see important messages/errors. – Ciprum May 22 '16 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.