1

My music library was in FLAC and MP3 formats. (MP3 for old time radio plays, FLAC for music.) I have been converting these files to ALAC in m4a files. This included cleaning up a real mess because a lot of files had sloppy tagging in them. I'm on OS X, if that will make a difference in what is available.

I want to read my files, both the older ones (in FLAC and MP3) and the newer m4a versions and be able to dump a lot of the tag information in a database where I can make it easier to compare the libraries and make sure I haven't skipped any FLAC files in the conversion process.

I'm using Python 2.7 on OS X (10.11.4) and using pip to install modules. Mutagen won't install because it needs to make a directory in the Python frameworks in /Library and the OS won't let it write there (either normally or with sudo). I tried installing fmoo-audiotools, but pip can't find it and gives me the same error message on that as it does if I try to install a non-existant module. I tried downloading AudioTools and installing, but it expects lame to be in its own source tree, and it's not included (I have it installed on my iMac, though - apparently the config file in AudioTools can't see it).

While it'd be nice to just get AudioTools or mutagen working (since the documentation is easy to follow for both of those), I'd be satisfied if I could get another Python module working so I can read the ID3 tags in all these files. However, when I search for modules that handle ID3 tags, other than the ones I've mentioned, they either don't specify what file format they support or only support MP3 and maybe one or two other formats.

Is there some way I can get mutagen or AudioTools to install or is there another module I can use to read the metadata in my FLAC, MP3, and ALAC files?

1

Here are 2:

pytaglib

eyeD3

To install them you can use

pip install pytaglib

or

pip install eyeD3

But keep in mind that pip always needs access to the lib folder to install almost any module. You should look into why you can't install the modules as it should not be a problem.

  • When I get back to my iMac, I'll check that out. It may be that whatever is going on is creating a real issue. I even tried, as root, to create the directory mutagen wanted and couldn't do it. This may turn into an Ask Different issue where I ask why Python modules won't install on El Capitan. I'll report back on that. – Tango Apr 22 '16 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.