1

I'm looking for a command-line spell checker for windows. Currently, GNU ASpell absolutely is not working out for me.

Neither the installed nor portable version. They would not even create console output. Not after 30 minutes of trying. And I've been building up on my command-line environment for 25 yrs. No dummy here. I'm not willing to spend more time on GNU Aspell. I place a 30-minute maximum on such things!

[UPDATE: Somehow, I got aspell working. Perhaps I found one in cygwin that worked? I forget what happened.]

1

One possible solution:

  1. Install python, accepting the option to add to the path,
  2. Use pip to install pyenchant, i.e.: pip install -U pyenchant
  3. Add to a file called spell.py, in a directory on your path:

Some python

"""
Command Line Spelling Checker
Enter words to check as arguments
"""
from __future__ import print_function
import sys
import enchant

d = enchant.Dict("en_US") # or en_UK, de_DE, fr_FR, en_AU on my system
print(__doc__)
for word in sys.argv[1:]: 
    if d.check(word):
        print(d, 'is OK')
    else:
        print('Suggestions for', word, ':', '\n\t'.join(d.suggest(word)))

Then add create a batch file called spell.bat, or whatever you wish, with @python spell.py %* in it.

Bingo you have your command line dictionary in less than half and hour, free, and on non-windows platforms you can skip the batch file and use aliases, on most you can skip installing python as it is probably there already.

  • I ended up getting GNU Aspell to work, so I can't evaluate your answer, but nobody else has answered, so in circling back, I'm going to accept yours :) – ClioCJS May 18 '16 at 20:21
  • Thanks for that might be worth adding A spell as you own answer. – Steve Barnes May 18 '16 at 20:23
  • The reason I didn't add it as my own answer is because my question excluded it. :) – ClioCJS May 22 '16 at 16:42
  • @ClintJCL - your question said "currently not working" so adding with how you got it working ... – Steve Barnes May 22 '16 at 17:15
  • Oh, if only I had the answer to that! The answer was "Frustratedely point myself at the computer until I gave up, then later notice that somehow the act of giving up seemed to have fixed it". It may be that I found an aspell.exe in my cygwin that worked better than the one I was building. But it was a late night, and unfortunately, absent someone recording my session, I don't actually know for sure what I did, sorry! ;) :) – ClioCJS May 24 '16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.