1

I have a Nexus 4 Android phone and I use Google Calendar to set up appointments and other important events with reminders so I won't forget about them. However when the phone triggers the reminder it just displays a calendar notification on the screen without any sound/vibration. This means that if I don't accidentally look at my phone just after the reminder has been displayed and the event starts I will miss the event, which happens frequently for me.

So I'm looking for some kind of calendar app or calendar reminder app for Android that will give me vibration/sound notifications whenever a Google Calendar reminder is triggered.

If there is some setting I've missed that you can change so the standard Google Calendar app uses sound and vibration for reminders that would be good enough for me to accept as an answer (possibly even ideal, unless there is some other app out there that's much better).

Wanted features:

  • The app should interact with Google Calendar and trigger on reminder information set in Google Calendar (see use case below).
  • It should be able to notify about upcoming calendar events with vibration and possibly also sound.
  • It should work all the time, that is I shouldn't have to start the app whenever I restart the phone.
  • It should not display any icon in the notification bar except for when it has issued a reminder. Then the reminder should be displayed in the notification bar.
  • It should preferably be free or cheap.
  • It would be nice to be able to choose which sound it should play for reminders, or disable sounds completely.

Use case:

I add a meeting for 13.00 on Wednesday with a reminder 5 minutes before in Google Calendar from my computer, the app on Android will then trigger a reminder at 12.55 on Wednesday by playing a sound and vibrate briefly.

  • Generally notifications on phones can be configured to provide audio/visual notifications...I can configure my gmail to do it...which makes me think gcalendar can do the same as well. Have you reviewed the notification settings on your phone? – James Mar 19 '14 at 13:21
  • Google calendar does this on all of my devices. Check calendar->settings->notifications. Make sure notifications are turned on, and have a non-silent ringtone, and that vibrate is turned on. Also make sure your device isn't silenced. I don't know if having pop-up notification does anything more or less on that score, so try it with that in both states. Also, if the google cal is set to use the default ringtone, make sure system settings->sound has a tone set for default notification. – Michael Kohne Mar 19 '14 at 13:22
  • @MichaelKohne I have been looking trough all kinds of settings without finding anything like this. But now I took another look at calendar->settings->notifications and sure enough there is a "vibrate" setting there that is not checked. A non-silent ringtone was set as well but the sound for that is pretty low so it could be that I don't hear it when I have the phone in my pocket. If you give your comment as an answer I'll accept it, this was exactly what I needed. – nibarius Mar 19 '14 at 13:34
  • It sure would be nice if there could be different vibration/sound notifications for different calendar events. Rather than all calendar notifications having the same vibe/sound/visual, if enabled for their calendar. // Most specifically, specify on a per event basis: e.g. I need to pick my daughter up after school, so I need a blaring alarm that I must hit to disable. But for m any items a much calmer alarm is enough. Just like I can have dofferent ringtones pr caller, I would like to have different vibe/sound/notes according to people in meeting. – Krazy Glew Nov 21 '14 at 21:36
  • E.g. I sometimes set up morse code-like ringtones for important callers. It would be nice to be able to have the Morse code go ("Meeting"/"Email"/"Text"/"Phone") ("Person"). // Such selectivity will become more important with watches - I do not want ALL notifications on my watch, only the most important. – Krazy Glew Nov 21 '14 at 21:38
2

Google calendar already does this.

In the calendar settings, look at the 'Notifications' section. Make sure notifications are turned on. Make sure that a non-silent ringtone is selected. Make sure that vibrate is turned on.

Also, if Google Calendar is set to use the system default notification ringtone, go into System Settings->Sound and make sure that a non-silent ringtone is set for notifications.

  • 1
    Also make sure that you go into Settings > Sounds to check the volume for the notification sounds is loud enough. I found that mine was set very low so that i wasn't hearing the notifications that I had setup. – user13817 Apr 20 '15 at 18:41
  • Also make sure your "Notification" volume slider is turned up. It's easy to forget that Android separates sound volumes by classification. – Ben Leggiero May 12 '17 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.