I ran into a service called Bitcasa Bitdrive today. What I like about it is the fact that it is so easy to mount a Bitdrive as a folder on Ubuntu (they only claim to work with Ubuntu 13.04- but as far as I can see it appears to work just fine on my 64 it Ubuntu 14.10 server.

In many ways what they are offering is perfect - a large volume of securely encrpyted cloud storage which I can mount as a shared drive across all my servers. Quite apart from the fact that they got some bad press towards the end of 2014 the one thing that bothers me is that they impose a constraint of 5 connected devices. This is not an immediate concern but will soon be one since I would like the ability to read/write to Bitdrive from as many as 15 servers spread across the world. My searches for a service that offers similar functionality - encryption, large storage capacity and easy access as a mounted folder - have drawn a blank. Perhaps someone here might be able to suggest a few alternatives? Thanking you in advance.

  • Can you play them to add more servers?
    – Mawg
    Mar 26, 2015 at 10:47

1 Answer 1


Have You ever tried Dropbox? It offers a similar cloud service as Bitcasa. You can mount your dropbox folder as a standard folder of your sistem, download and upload files and folders, via OS or via its Web GUI.
I don't know if Dropbox has any limitation about connected devices.
Dropbox also offers its SDK suite, to integrate cloud service in Android Application, Python/Java/PHP Application.. But, consider that the amount of storage is less then Bitcasa Service, You can increase your storage amount inviting your friends.

  • I was attracted to ByteCasa because they offer as much as 100 Terabytes of storage at what is a fairly reasonable price. Whether they can actually deliver there is another question (given the recent bad press). I suppose the real proof of the pudding lies in the eating.
    – DroidOS
    Mar 26, 2015 at 12:42
  • What matters is how it works! I have seen the pricing of Bitcasa, it looks very good. The premium version is almost the same of Pro version of dropbox. I havent' found the 100TB option, where is it?
    – Filadelfo
    Mar 26, 2015 at 13:34
  • I put in an extra 0 - 10 Terrabytes is what that should read. This might be an Ubuntu 14.04 issue (they do say that their Linux headless client is tested up to Ubuntu 13.04) - when I rebooted and remounted I started getting strange errors. ls for the mounted folder returned nothing, newly created files there did not appear in their web ui... . So , much though I would like to find that Bitcasa offer what I need I still have lingering doubts.
    – DroidOS
    Mar 26, 2015 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.