33

I'm looking for a solution that lets me 'mount' a remote server via ssh or sftp protocols.

  • The remote directory should show up as a drive letter on Windows.
  • (optional) More than one simultaneous connection possible.
  • Free or paid solutions are acceptable.
  • Windows 7 is a must.

Things I've tried so far:

  • sshfs - This mostly works, but for some reason when you use Notepad++ to access files over an sshfs connection, Notepad++ can't properly determine line endings. Also has some bugs in the UI (you have to save the password to get it to work), and the developer appears to be absent.
  • SFTP Net Drive - The free version works, but I get frequent 20 second pauses in open dialogs. Given that the 'server' is a VM running locally, this isn't a network issue, and it DOESN'T happen with sshfs.
  • ExpanDrive - Seems to be working in my initial tests. No odd lags or bad behaviors. I wouldn't mind a slimmer solution (it supports N different cloud providers as well as SFTP), but it DOES work.

I'd obviously like a free solution, but if none exists, I'll happily pay money for something.

Update: I've added answers below with the ones I've actually had some success with.

21

Out of the ones you listed: I would be cautious with sshfs as the underlying driver (Dokan) has not been updated for quite a while, and even though it supports Windows 7, it has known issues with Windows 8.x (and probably with Windows 10).

ExpanDrive works like a charm, and I don't see the need for a "slimmer solution", you can simply not use the protocols you don't need.

I'm surprised by the behavior you describe regarding SFTP Net Drive; I have it installed at many customers' locations and it's probably the most reliable piece of software I've ever tried (when properly configured). Personally, out of 100+ installations, I've never seen the behavior you describe.

Another excellent option that you may consider is WebDrive. Like ExpanDrive it supports a plethora of protocols, but don't be intimidated, it's easy to use and fairly lightweight.

Also, you may check out NetDrive; very similar to ExpanDrive and WebDrive, with a wide support for many back-ends, and a clean and easy-to-use configuration interface.

  • Do WebDrive and NetDrive actually mount the remote (giving it a drive letter)? I kind of had the impression that they were kind of Explorer add-in things, but that they didn't really present a drive to the system. – Michael Kohne Nov 14 '14 at 16:03
  • Nope, both of them DO actually mount your remote server as a drive (with drive letter) in Windows. Download them and try yourself. :) – FjodrSo Nov 14 '14 at 19:47
  • Interesting: I had small troubles with ExpanDrive (it would sometimes exit without warning when disconnecting a drive). While removing it to try WebDrive, I found the Dokan library still in place, and I wonder if it was causing trouble for sftp net drive and expandrive. – Michael Kohne Nov 20 '14 at 13:17
  • WebDrive triggers bad behavior in Notepad++ - for some reason after every save, Notepad++ thinks the file has been changed and reloads it. – Michael Kohne Nov 20 '14 at 13:33
  • 1
    NetDrive may be easy to configure, but for some reason I can't get it to talk to the system in question, and it's error message is completely useless. – Michael Kohne Nov 20 '14 at 14:08
5

There are some forks of win-sshfs and the Dokan library, which seem to get it working much better.

https://github.com/dokan-dev/dokany

https://github.com/dimov-cz/win-sshfs

https://github.com/tuiSSE/win-sshfs (with a very different GUI and more than 300 commits over the original win-sshfs; however, it is no longer being developed, it asked to be merged into dimov-cz).

I've tried both of these forks, and they seem to work reasonably well regarding transfer speed and latency. None of them is able to restore connection after network connection is lost or after wakeup from sleep. On the other hand, they work flawlessly in Explorer and other file managers. They both run (at least) on Win 7 64bit.

The dimov-cz fork takes about 30 MB of RAM, the tuiSSE takes almost 80 MB RAM.

  • You can generate a rsa-key when you install git-scm. rsa-keygen -t rsa -b 4096 ==> C:/Users/<YOUR_USER>/.ssh/id_rsa.pub then echo id_rsa.pub on the server to /home/<your_accessed_user>/.ssh/authorized_keys – Stefan Steiger Oct 2 '16 at 18:18
  • @StefanSteiger: ??? I already use key-based login... – Martin Pecka Oct 3 '16 at 6:38
4

I am using NetDrive 1.3.4, which is the last version free for non-commercial home use, and it works fine on Windows 8.

  • netdrive is no longer free for home use. it's a 30 day trial, then you purchase – Ryan Teemer Apr 1 '15 at 20:12
  • 3
    NetDrive 2.* is trialware, but 1.* is freeware. – niutech Apr 4 '15 at 0:02
  • From what I can tell, 1.3.4.0 does not support any form of encryption just raw FTP and WebDAV. – Enigma May 8 '15 at 15:53
3

I did try WebDrive, and (after some back and forth with the developers) got it working perfectly. The secret is to disable all caching AND the asnyc option. You have to do BOTH in order to get it to work reliably with Notepad++.

The only downside relative to ExpanDrive is that the license is per machine, not per user, so if you have more than one computer, WebDrive would be more expensive.

  • One more thing: it may also be necessary to turn of the 'Enable Delayed Close' feature for perfect handling with Notepad++. – Michael Kohne Nov 11 '15 at 19:30
3

ExpanDrive works for me, and their licensing (per-user, not per computer) is very reasonable.

This is the one I ended up buying. I do have an issue (I'm going to submit a support ticket today) where it has a tendancy to pause for 10-20 seconds when first opening a directory.

Updated: After several months use, I'm less fond of ExpanDrive than when I started out. I did submit a ticket about the lags, but never got a real fix, nor did I pursue it. More importantly, I've run into an odd behavior that I think I have to attribute to caching: Sometimes, when I change a folder on the target system directly, it isn't properly reflected on the Windows system that's using ExpanDrive.

In one case, I renamed a folder using an ssh command line to the target. I then used Notepad++ on the Windows system and found BOTH the old and new names were showing up in the open file dialog! I can't reproduce this on demand, so I haven't submitted a ticket yet, and I'm also a version or two behind the latest.

  • And on further issues with Expandrive: for unknown reasons it's window stopped showing up, making it impossible to use. I updated and now there seems to be some sort of caching issue causing bad behavior in Notepad++. – Michael Kohne Oct 12 '15 at 17:02
0

If you're still ISO a Windows SSHFS client, I'm using MountainDuck, which is authored by the same folks as CyberDuck FTP client. I like the SSH key feature. The biggest advantage I can see is that you don't have to open additional ports on a router or create extra firewall rules. It mounts the remote FS as a drive letter, but I'd rather have the option of mounting as a UNC path because I have a lot of network volumes in use.

The Windows client is compatible with 7 and up. There's a Mac version as well. The (cheap, paid) license allows installation on multiple machines.

It supports FTP, FTP-SSL, SFTP, WebDAV, Amazon S3, Backblaze cloud storage, Google Cloud Storage, Rackspace Cloud Files, Swift, Windows Azure Storage, Dropbox, Google Drive, MS One Drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.