Executing Python in the Command Prompt causes some problem for entering data in UTF-8. in my case command prompt and subsequently Python shell doesn't show Persian characters correctly. I changed the Active Page Encoding by chcp 65001, changed the console font ... no result

Then I look for an alternative shell for Python (an interpreter) which

  • Does anything Python interpreter does
  • Support Arabic or Persian languages (to type some data not instructions)

1 Answer 1


As far as I understand, you want to interactively type in said data at the prompt, while your Python script is running. (Otherwise, the most-likely already-installed Windows PowerShell ISE would have sufficed.)

Take a look at Dreampie - it is UTF-8-enabled, both in interactive and scripting mode. Although you didn't specify the Python version you are using, it supports both 2 and 3. (As a bonus, it is cross-platform. It also features a few other feats that I appreciate as a developer.)

IDLE, the built-in Python IDE, as far as I know, doesn't support UTF-8 in the interactive mode.

(Although I didn't use Dreampie with Python 3.2, nor higher, I'll add this, just in case the bug is still relevant and you have trouble making it work for you.)

  • thank you, I tested PowerShell, and unfortunately have the same problem and can't type in Persian, I also used DreamPie and now Wing IDE, there I can type in Persian, just for the output Python shows my strings as some \u Some codes, how can I show them exactly as what I input
    – Ahmad
    Oct 4, 2014 at 5:43
  • See if this helps you, especially the first answer (not the chosen one). If not, I think you should post the question on Stackoverflow, preferable with a relevant code snippet, mentioning Dreampie. Also, this is rather for other people that might read: PowerShell is different from PowerShellISE. Oct 4, 2014 at 10:19
  • Also, scratch the IDLE suggestion, per: stackoverflow.com/questions/15196321/…. Oct 4, 2014 at 14:37
  • Thank you, DreamPie solved my problem for input and output in Persian, just I got another problem with it which has been asked here stackoverflow.com/questions/26202255/…
    – Ahmad
    Oct 5, 2014 at 13:03
  • @Ahmad Awesome, could you please share for others what you did to make it work for you, since you mentioned initially that it failed on output? Was it my suggestion or a code issue that you solved? Oct 5, 2014 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.