1

I have a Samsung Galaxy S2 and I play INGRESS and Geocaching. The S2 has a built in "static navigation disable" filter, which means that if your velocity is under a certain threshold (I think is 4Km/h) the updates in the position coming from the GPS are NOT sent to any app. The goal is to prevent your position from wandering when you are not moving but: when you are geocaching and you walk some meters, you want this update to appear in your GPS app.

Every single forum points to GPS Control SiRF Donate, but it was discontinued on 2012 and does not work for newer android versions.

Does anyone know about a new app or something? I did root my cellphone for testing the app so, if rooting or scripting is needed, I can go for it.

Details from the cellphone:

GT-I9100 Android 4.1.2 base-band : I9100XXMS4 Kernel : 3.0.31-1497824 dpi@DELL133#3 SMP PREEMPT Mon Dec 23 Compilation num: JZO54K.I9100XWMS3

GPS chipset, unknown (if someone provides instructions for how to get this) I will update it.

I found this other source here, but I dont know what "ROM" do I have. .so not sure if it will work for me, can someone help in that direction ?

I also found here a link for downloading an egg that seems to have the patch to fix it but .. no documents on how to apply it or what android versions are supported.. :(

  • @Izzy I found another source, but Im not sure if that's good for me, check edits, please – javirs Sep 4 '14 at 7:56
  • My French isn't that good, but I suppose would you run a 2.2/2.3 ROM you could stick with the original app (check Settings→About to see your Android version). From your description, ROM Stock Samsung 4.0.3 → 4.1.2 should match. The XDA patch requires a custom recovery (CWM), and seems to toggle on each boot by patching the library; you could try following the steps manually once to have it "permanently fixed" instead. – Izzy Sep 4 '14 at 11:18
  • sorry I dont get it .. if the patch works for 2.2*2.3 why is my 4.1.2 ok? should I downgrade to use the patch? doesnt sound like a fair trade :( – javirs Sep 4 '14 at 11:46
  • As said, I cannot speak French well (and GTrans doesn't work as the page uses JavaScript too heavily). Ne fonctionne pas avec les ROMS en 2.x → does not work with 2.x; Liste des ROMS et applications de Navigation compatibles: [..] ROM Stock Samsung 4.0.3 → 4.1.2 → "Android 4.1.2" as per your question. What I meant in my previous comment is: if you were on 2.2/2.3, you could stay with "GPS Control SiRF" (supported for Android 2.x). Comments do not offer much formatting options, sorry ;) – Izzy Sep 4 '14 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.